Subject: Re: kern.showallprocs implementation
To: Elad Efrat <>
From: Rui Paulo <>
List: tech-kern
Date: 08/29/2005 23:03:59
Content-Type: text/plain; charset=us-ascii
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable

On 2005.08.29 14:20:06 +0000, Bill Studenmund wrote:
| On Mon, Aug 29, 2005 at 11:39:51PM +0300, Elad Efrat wrote:
| > Bill Studenmund wrote:
| >=20
| > [...]
| > > So my vote is go with one knob now and see what folks experience. If =
| > > have folks who find they really want to let a user see one thing or t=
| > > other, then we can revisit.
| >=20
| > Okay.
| >=20
| > Would you object to adding a sysctl node named ``security'' (either
| > under ``kern'' or as a new main one), and underneath it another node,
| > ``privacy'', and underneath it a knob similar to ``see_other_uids''?
| Why not just use the FreeBSD name? If there is a good reason to use a=20
| different name, so be it. But I am not sure that we have heard one. We=20
| will (I expect) want to support it for FreeBSD compat, so if there is no=
| reason to be different, why not just make them the same?

I prefer:
And no variables_like_this_one. It's ugly, IMHO.

| Also, I am partially enamored of what FreeBSD has done with the naming
| here. They are indicating. with the "bsd" node under "security", that
| these controls/status are part of the "bsd" security model. Yes, "unix" =
| could have been used, as well as "uid/gid" (but that seems unwieldy). But
| we leave space for future models, which our discussions indicate may soon=
| be coming (well, I hope so :-). [...]

I agree. FreeBSD folks have security.bsd.* and security.jail.* and that
seems to be well organized:

Also, Elad's code works perfectly after my netstat(1) changes, so we have
1) working code; 2) a discussion on which sysctl variable to use;

2) should end ASAP!

		-- Rui Paulo

Content-Type: application/pgp-signature
Content-Disposition: inline

Version: GnuPG v1.4.1 (NetBSD)