Subject: Re: 64 bit inode changes
To: None <email@example.com>
From: Joerg Sonnenberger <firstname.lastname@example.org>
Date: 08/16/2005 15:56:43
On Tue, Aug 16, 2005 at 03:28:03PM +0200, Joerg Sonnenberger wrote:
> On Tue, Aug 16, 2005 at 12:32:41AM +0000, Christos Zoulas wrote:
> > In article <20050815233221.GB1595@britannica.bec.de>,
> > Joerg Sonnenberger <email@example.com> wrote:
> > >> Sounds like fine names to me. I will change mine. Does your ALLOC take
> > >> one or two arguments? What about NEXT?
> > >
> > >_DIRENT_ALLOC takes one argument, the length of the filename.
> > And returns a size, right? Then a better name would be _DIRENT_RECLEN(). I
> > am passing the struct too, for symmetry with DIRENT_ADVANCE.
> I intended to use it for allocation for dirents, e.g. by callers of
> readdir_r. You don't have a struct dirent there.
Actually, we want to have both. I've used _DIRENT_DIRSIZ for the version
with struct dirent * as argument, but _DIRENT_RECLEN is better.