Subject: Re: 64 bit inode changes
To: None <>
From: Joerg Sonnenberger <>
List: tech-kern
Date: 08/16/2005 15:28:03
On Tue, Aug 16, 2005 at 12:32:41AM +0000, Christos Zoulas wrote:
> In article <>,
> Joerg Sonnenberger  <> wrote:
> >> Sounds like fine names to me. I will change mine. Does your ALLOC take
> >> one or two arguments? What about NEXT?
> >
> >_DIRENT_ALLOC takes one argument, the length of the filename.
> And returns a size, right? Then a better name would be _DIRENT_RECLEN(). I
> am passing the struct too, for symmetry with DIRENT_ADVANCE.

I intended to use it for allocation for dirents, e.g. by callers of
readdir_r. You don't have a struct dirent there.

> >_DIRENT_NEXT works just like your DIRENT_ADVANCE.
> I pass the struct here, so that I can re-use the macro for struct direct
> and struct dirent12 (our compat code). If we don't have the same arguments,
> then it is not worth to call them the same name.

Misunderstanding, they take the same argument.