Subject: Re: making an existing feature optional (Re: CVS commit:
To: None <>
From: YAMAMOTO Takashi <>
List: tech-kern
Date: 08/10/2005 08:05:18
> > I'd go for having the "allow overriding options" part, and then adding
> > "options VMSWAP" to the various std.${ARCH} files, or even better,
> > having them include a conf/std file which would contain
> > "options VMSWAP", and leave room for other stuff (like, say, INET).
> This sounds good to me - better than introducing additional semantics for 
> options (option, no option, now default option?!).

we are talkinkg about additional semantics, whatever it's called.
if you don't like the name "default-options",
it can be just named "options", as i said in the first mail.
it isn't the important point.

another reason i prefer to put them in files.* is modularity.
it isn't a good idea to spread the knowledge of an option
to many places, IMO.