Subject: Re: making tpcalib MI
To: None <>
From: TAKEMURA Shin Takemura <>
List: tech-kern
Date: 05/30/2004 17:58:11
From: Matthew Orgass <>
Subject: Re: making tpcalib MI
Date: Wed, 26 May 2004 17:24:29 -0400 (EDT)

> On 2004-05-26 wrote:
> > In article <> you write:
> > >   IMO, GETID should go in the individual drivers since it has nothing to
> > > do with calibration in particular.  I don't know if there is another
> > > convienient place to share the code, but copy&paste should be fine.
> >
> > Your later message complains, I think, that hpc_tpcalib is a bad name
> > for something that doesn't really have anything to do with calibration
> > anymore.  I agree with that, but sharing the code till seems good.
> > Consider the proposal modifed to now call that hpc_tpanel, with a
> > hpc_tpanel_ioctl() function.
>   Thinking about it a bit more, I really think what this code is doing
> (using platform and model as the device name) is wrong.  The only
> potential use I can think of is to allow a userland version of the current
> kernel machine type based default calibration settings.  But calibration
> can change between individual machines of the same type (otherwise CE
> would not need user calibration) and having a default prevents automatic
> user calibration.  I would say selecting on any name not supplied by the
> user is wrong, and the best thing to do would be to remove the GETID
> implementation entirly (or have it return a description of the particular
> controller for potential informational messages) and just have one
> calibration per file.

Please note that a root file system might be shared by two or more 
machines if root device is removable. For example, I have dozen MIPS 
base handhelds with touch panels and only one micro drive for root FS.

Ideally, the GETID returns GUID (global unique ID) for the touch 
panel. The current implementation returns magic string, which contains
model name and serial number. If serial number is not available on the
machine, zero will be used instead. That is the reason the GETID seems
to just returns model name.