Subject: Re: making tpcalib MI
To: Ty Sarna <firstname.lastname@example.org>
From: Matthew Orgass <email@example.com>
Date: 05/26/2004 17:24:29
On 2004-05-26 firstname.lastname@example.org wrote:
> In article <Pine.BSF.email@example.com> you write:
> > IMO, GETID should go in the individual drivers since it has nothing to
> > do with calibration in particular. I don't know if there is another
> > convienient place to share the code, but copy&paste should be fine.
> Your later message complains, I think, that hpc_tpcalib is a bad name
> for something that doesn't really have anything to do with calibration
> anymore. I agree with that, but sharing the code till seems good.
> Consider the proposal modifed to now call that hpc_tpanel, with a
> hpc_tpanel_ioctl() function.
Thinking about it a bit more, I really think what this code is doing
(using platform and model as the device name) is wrong. The only
potential use I can think of is to allow a userland version of the current
kernel machine type based default calibration settings. But calibration
can change between individual machines of the same type (otherwise CE
would not need user calibration) and having a default prevents automatic
user calibration. I would say selecting on any name not supplied by the
user is wrong, and the best thing to do would be to remove the GETID
implementation entirly (or have it return a description of the particular
controller for potential informational messages) and just have one
calibration per file.
> > I think it is only hpcfb specific by using the extended configuration
> > info that is needed for hpc frame buffers. For many other frame buffers
> Well, besides being hpcfb-specific, it's fb-specific. That's not going
> to work on i386 except with uwscons, I suppose. Even then, you really
> need to calibrate in the same display mode you'll be using it in.
I thought a vga frame buffer was available, but I guess not. I was
thinking of LCDs; if the device could be used on CRTs then mode does
> > An additional X utility would be good too. It might also be reasonable to
> > do a text-only "touch what you want to be the corners" mode.
> That would only be useful for using the touchpanel with curses apps or
> the like, I think.
Or for LCD displays, but if your device is for CRTs then that would be
the only use.