Subject: Re: making tpcalib MI
To: None <firstname.lastname@example.org>
From: Ty Sarna <email@example.com>
Date: 05/26/2004 08:47:04
In article <Pine.BSF.firstname.lastname@example.org> you write:
> IMO, GETID should go in the individual drivers since it has nothing to
> do with calibration in particular. I don't know if there is another
> convienient place to share the code, but copy&paste should be fine.
Your later message complains, I think, that hpc_tpcalib is a bad name
for something that doesn't really have anything to do with calibration
anymore. I agree with that, but sharing the code till seems good.
Consider the proposal modifed to now call that hpc_tpanel, with a
> I think it is only hpcfb specific by using the extended configuration
> info that is needed for hpc frame buffers. For many other frame buffers
Well, besides being hpcfb-specific, it's fb-specific. That's not going
to work on i386 except with uwscons, I suppose. Even then, you really
need to calibrate in the same display mode you'll be using it in.
> An additional X utility would be good too. It might also be reasonable to
> do a text-only "touch what you want to be the corners" mode.
That would only be useful for using the touchpanel with curses apps or
the like, I think.