Subject: re: switch to two-argument KASSERT?
To: matthew green <>
From: Ben Harris <>
List: tech-kern
Date: 01/15/2004 13:55:39
On Fri, 16 Jan 2004, matthew green wrote:

> i'd rather rename the current KASSERT() to KASSERT1() and use the
> old name for the new macro.  that gives us compatibility with
> freebsd, and this macro is one of the few things i hit _every_
> _time_ i port freebsd code...

Good point.  I suspect that people who aren't me port stuff from FreeBSD
more often than they dig it out of ancient patches.

Ben Harris                                                   <>
Portmaster, NetBSD/acorn26           <URL:>