Subject: Re: atareg.h macro naming rule
To: YAMAMOTO Takashi <>
From: Manuel Bouyer <>
List: tech-kern
Date: 11/29/2003 16:14:46
On Fri, Nov 28, 2003 at 11:03:43PM +0900, YAMAMOTO Takashi wrote:
> > No, these are ATA specific. 
> i misread your argument, sorry.
> then, WDC_CAP_LBA48 and WDC_CAP_QUEUE should be renamed, right?


> i doubt if separated flags for "enabled" registers are needed, though.

probably not. WDC_CAP_LBA48 should be below atap_cmd_set2, with others.
WDC_CAP_QUEUE should be deleted.

Manuel Bouyer <>
     NetBSD: 24 ans d'experience feront toujours la difference