Subject: Re: atareg.h macro naming rule
To: None <firstname.lastname@example.org>
From: YAMAMOTO Takashi <email@example.com>
Date: 11/28/2003 23:03:43
> > > > WDC_ is for ata/atapi, ATA_ is for ata only.
> > >
> > > Yes.
> > > I didn't check recently, but I don't think there are atapi-specific bits yet
> > > (at last not in our atareg.h file)
> > we have ATA_CMD2_APM, ATA_CMD2_CFA, ATA_CMD2_RWQ.
> > all of them are not atapi specific, IIRC.
> No, these are ATA specific.
i misread your argument, sorry.
then, WDC_CAP_LBA48 and WDC_CAP_QUEUE should be renamed, right?
i doubt if separated flags for "enabled" registers are needed, though.