Subject: Re: atareg.h macro naming rule
To: None <email@example.com>
From: YAMAMOTO Takashi <firstname.lastname@example.org>
Date: 11/28/2003 10:06:25
> > > they seem very inconsisitent to me.
> > > i'd like to add definitions for some new bits
> > > but i'm not sure which prefix i should use.
> > > WDC_CMD2_, WDC_CAP_, ATA_CMD2_, or something else?
> > WDC_ is for ata/atapi, ATA_ is for ata only.
> I didn't check recently, but I don't think there are atapi-specific bits yet
> (at last not in our atareg.h file)
we have ATA_CMD2_APM, ATA_CMD2_CFA, ATA_CMD2_RWQ.
all of them are not atapi specific, IIRC.
do you mean, they should be renamed to WDC_ ?
and how about ATA_CAP_ ?
> > > any ideas? is it ok to rename them to have the same prefix?
> No, the different prefixes are on purpose (although not documented, I admit :)
document, please :)