Subject: Re: atareg.h macro naming rule
To: None <email@example.com>
From: YAMAMOTO Takashi <firstname.lastname@example.org>
Date: 11/28/2003 00:31:32
> > defined in sys/dev/ata/atareg.h, are named like:
> > WDC_CMD2_DM
> > ATA_CMD2_RWQ
> > WDC_CAP_LBA48
> > WDC_CAP_QUEUE
> > (note that ATA_CMD2_RWQ and WDC_CAP_QUEUE are for
> > the same bit, "READ/WRITE DMA QUEUED supported".)
> No, ``supported'' and ``enabled''.
do you mean, we should use different set of macros for
"supported" and "enabled"?
> > they seem very inconsisitent to me.
> > i'd like to add definitions for some new bits
> > but i'm not sure which prefix i should use.
> > WDC_CMD2_, WDC_CAP_, ATA_CMD2_, or something else?
> WDC_ is for ata/atapi, ATA_ is for ata only.
such criterion doesn't seem to be held, at least currently..