Subject: Re: atareg.h macro naming rule
To: Alexander Yurchenko <>
From: Manuel Bouyer <>
List: tech-kern
Date: 11/27/2003 23:53:29
On Thu, Nov 27, 2003 at 05:15:55PM +0300, Alexander Yurchenko wrote:
> > they seem very inconsisitent to me.
> > i'd like to add definitions for some new bits
> > but i'm not sure which prefix i should use.
> > WDC_CMD2_, WDC_CAP_, ATA_CMD2_, or something else?
> WDC_ is for ata/atapi, ATA_ is for ata only.

I didn't check recently, but I don't think there are atapi-specific bits yet
(at last not in our atareg.h file)

> > any ideas?  is it ok to rename them to have the same prefix?

No, the different prefixes are on purpose (although not documented, I admit :)

Manuel Bouyer <>
     NetBSD: 24 ans d'experience feront toujours la difference