Subject: Re: atareg.h macro naming rule
To: YAMAMOTO Takashi <firstname.lastname@example.org>
From: Alexander Yurchenko <email@example.com>
Date: 11/27/2003 18:43:15
On Fri, Nov 28, 2003 at 12:31:32AM +0900, YAMAMOTO Takashi wrote:
> > > defined in sys/dev/ata/atareg.h, are named like:
> > > WDC_CMD2_DM
> > > ATA_CMD2_RWQ
> > > WDC_CAP_LBA48
> > > WDC_CAP_QUEUE
> > > (note that ATA_CMD2_RWQ and WDC_CAP_QUEUE are for
> > > the same bit, "READ/WRITE DMA QUEUED supported".)
> > No, ``supported'' and ``enabled''.
> do you mean, we should use different set of macros for
> "supported" and "enabled"?
well, since bits are the same may be not...
> > > they seem very inconsisitent to me.
> > > i'd like to add definitions for some new bits
> > > but i'm not sure which prefix i should use.
> > > WDC_CMD2_, WDC_CAP_, ATA_CMD2_, or something else?
> > WDC_ is for ata/atapi, ATA_ is for ata only.
> such criterion doesn't seem to be held, at least currently..
May be you just tell what bits you wanna add?
> YAMAMOTO Takashi
Alexander Yurchenko (aka grange)