Subject: Re: atareg.h macro naming rule
To: YAMAMOTO Takashi <email@example.com>
From: Alexander Yurchenko <firstname.lastname@example.org>
Date: 11/27/2003 17:15:55
On Thu, Nov 27, 2003 at 11:02:57PM +0900, YAMAMOTO Takashi wrote:
> bits in the features supported/enabled register,
> defined in sys/dev/ata/atareg.h, are named like:
> (note that ATA_CMD2_RWQ and WDC_CAP_QUEUE are for
> the same bit, "READ/WRITE DMA QUEUED supported".)
No, ``supported'' and ``enabled''.
> they seem very inconsisitent to me.
> i'd like to add definitions for some new bits
> but i'm not sure which prefix i should use.
> WDC_CMD2_, WDC_CAP_, ATA_CMD2_, or something else?
WDC_ is for ata/atapi, ATA_ is for ata only.
> any ideas? is it ok to rename them to have the same prefix?
> YAMAMOTO Takashi
Alexander Yurchenko (aka grange)