Subject: atareg.h macro naming rule
To: None <email@example.com>
From: YAMAMOTO Takashi <firstname.lastname@example.org>
Date: 11/27/2003 23:02:57
bits in the features supported/enabled register,
defined in sys/dev/ata/atareg.h, are named like:
(note that ATA_CMD2_RWQ and WDC_CAP_QUEUE are for
the same bit, "READ/WRITE DMA QUEUED supported".)
they seem very inconsisitent to me.
i'd like to add definitions for some new bits
but i'm not sure which prefix i should use.
WDC_CMD2_, WDC_CAP_, ATA_CMD2_, or something else?
any ideas? is it ok to rename them to have the same prefix?