Subject: lockup using 1.6.1, cgd(4), raid(4)
To: None <>
From: None <>
List: tech-kern
Date: 11/03/2003 00:16:18

first, excuse the web mailer. My system is currently in a kind of flux since
not everything works as expected right now.

I'm currently trying to use 1.6.1_STABLE together with RAIDframe and Todd
Vierling's backported cgd(4) as of 2003-10-05. I have 4 disks wd2, wd3, wd4 and
wd5, each 160GB in size. On top of these sits raid0 in a RAID5 config.
Finally, cgd0 sits on top of raid0 using a 128bit blowfish key.

Recently I had tried using a 256bit blowfish key, which worked. Then the
system locked up as follows and I blamed the non-documented use of such a big
key size for blowfish. So I stepped back to a 128bit key and retried. I managed
to fill about 25GB of the ~447GB (Net/FreeBSD source trees, some files as
big as 7GB and other stuff) when the system locked up again.

The lockup is not total. A SSH session remains responsive, i.e. I can press
enter and receive feedback. However, whenever I try to access disks (both
cgd0 and wd0 which is unrelated to the raid and serves as the boot disk) the
session hangs. Also, the serial console becomes completely unresponsive (the
system is headless). I get no panic or reboot. The system also stops routing

Note that the initial parity rewrite went flawlessly (takes 5hrs) as did
newfs and fsirand (take considerable time as well). The whole setup performs at
about 6-7MB/s writing speed so it also takes quite some time to fill 25GB.

Please help me. I don't even know where to start looking. I'll happily
provide more info if needed.

NEU FÜR ALLE - GMX MediaCenter - für Fotos, Musik, Dateien...
Fotoalbum, File Sharing, MMS, Multimedia-Gruß, GMX FotoService

Jetzt kostenlos anmelden unter

+++ GMX - die erste Adresse für Mail, Message, More! +++