Subject: Re: Simplify pmap->uvm reporting of KVA boundaries
To: Chris Jepeway <firstname.lastname@example.org>
From: Jason Thorpe <email@example.com>
Date: 05/05/2003 14:47:01
On Sunday, May 4, 2003, at 12:42 PM, Chris Jepeway wrote:
> This code suggests to me that "virtual_avail" is
> the start of KVA.
Well... it's the first available address when the managed KVA (i.e.
kernel_map) is set up, and thus defines the start of managed KVA.
>> + virtual_avail = VM_MIN_KERNEL_ADDRESS;
>> + virtual_end = VM_MAX_KERNEL_ADDRESS - PAGE_SIZE;
> Why not call it virtual_begin to match the name virtual_end?
> virtual_avail seems to mean "total amount of available VM,"
> and that the start addr of KVA should be virtual_end - virtual_avail.
Most pmaps called this "virtual_avail". I'd rather make the name
change happen in a later commit, as a name change has no functional
-- Jason R. Thorpe <firstname.lastname@example.org>