Subject: Re: Simplify pmap->uvm reporting of KVA boundaries
To: Chris Jepeway <>
From: Rafal Boni <>
List: tech-kern
Date: 05/05/2003 14:33:46
In message <>, you write: 

-> > Comments appreciated... of course I'll also update the pmap(9) 
-> > documentation when I get ready to check the patch in.
-> Just some naming pedantry...
-> This code suggests to me that "virtual_avail" is
-> the start of KVA.
-> > +	virtual_avail = VM_MIN_KERNEL_ADDRESS;
-> > +	virtual_end = VM_MAX_KERNEL_ADDRESS - PAGE_SIZE;
-> Why not call it virtual_begin to match the name virtual_end?
-> virtual_avail seems to mean "total amount of available VM,"
-> and that the start addr of KVA should be virtual_end - virtual_avail.

I'll echo Chris' suggestion, but other than that, I think this is goodness;
I got pretty confused by the multiple layers of stuff from the hardcoded
#defines to the pmap_virtual_space to the UVM/pmap state variables.


Rafal Boni                                           
  We are all worms.  But I do believe I am a glowworm.  -- Winston Churchill