Subject: Re: Simplify pmap->uvm reporting of KVA boundaries
To: Jason Thorpe <>
From: Chris Jepeway <>
List: tech-kern
Date: 05/04/2003 15:42:06
> Comments appreciated... of course I'll also update the pmap(9) 
> documentation when I get ready to check the patch in.
Just some naming pedantry...

This code suggests to me that "virtual_avail" is
the start of KVA.
> +	virtual_avail = VM_MIN_KERNEL_ADDRESS;
> +	virtual_end = VM_MAX_KERNEL_ADDRESS - PAGE_SIZE;

Why not call it virtual_begin to match the name virtual_end?
virtual_avail seems to mean "total amount of available VM,"
and that the start addr of KVA should be virtual_end - virtual_avail.

>          -- Jason R. Thorpe <>
Chris <>.