Subject: Re: NO_PGID definition
To: None <>
From: Christos Zoulas <>
List: tech-kern
Date: 03/21/2003 15:40:31
In article <>,
Jaromir Dolecek <> wrote:
>I'm not sure if it's bug or intended, but I noticed NO_PGID
>is defined as
>	(-(pid_t)1)
>shouldn't it be
>	((pid_t)-1)
>Maybe it even doesn't make any difference, but the latter for is
>more readable IMHO.

Yes, it should. It does not make a difference right now, but it should
be changed.