Subject: Re: kern/18799 [Was: slip broken -- can someone look at PR #18799]
To: Jeremy C. Reed <>
From: Tomasz Luchowski <>
List: tech-kern
Date: 02/28/2003 11:57:45
On Wed, Feb 26, 2003 at 04:36:47PM -0800, Jeremy C. Reed wrote:
> I saw several months ago that I could not do slip from 1.5.x to a 1.6 box.
> Now, I see that 1.6 to 1.6 doesn't work either.

Hi Jeremy,

Unfortunately I have a similar problem. One box is running 1.6,
the other is 1.6.1_RC2. I set it up this way:

On the first box:
	slattach /dev/tty01
	ifconfig sl0

On the second:
	slattach /dev/tty00
	ifconfig sl0

I am connecting via ftp from "first" to "second", doing "get /netbsd",
but regularly it stops working after some time. I have never
been able to get as little as 500KB of this file.
Suddenly (but it happens every time) it stops working,
and even ping does not work. I don't do anything in either box
when the transfer takes place.

When I kill slattach and set everything up again, it works again,
but again fails after some activity.

I don't think it's ftp what causes problems, but "high" traffic
has been a very reliable way to stop it working every time I tried.
I haven't seen this problem when I only used telnet or ssh.

I have tried doing this with "default" speed and with 115200 as well,
both misbehave.

/* Tomasz Luchowski <> */