Subject: nullfs still doesn't reclaim space (PR#15555)
To: None <>
From: Jeremy C. Reed <>
List: tech-kern
Date: 02/11/2003 21:47:56
I use mount_null with mount_mfs on live CDs (memory- and cd-based) for
teaching classes and giving presentations.

Almost a year ago, I received a patch from enami t. for netbsd-1.5 so
nullfs would reclaim space. I think it was This worked
great for my 1.5.* based CDs.

I was guessing/hoping that 1.6 had this problem fixed.

In my last class, I accidently untarred the apache tarball on the wrong
mfs, and when I deleted the files (and they weren't in use), my file
system was still 101% full. So I rebooted, which caused another unrelated
issue -- the overhead video projection wouldn't sync anymore :(

Anyways, will someone look at enami's patch and PR #15555?

You can see some discussion also in the March 2002 tech-kern mailing
lists: "mount_mfs (with mount_null) won't reclaim space" and "CVS commit:

Also, I don't know if related, but with 1.5.*, doing a tail(1) of a file
under the mount_null/mount_mfs combination often wouldn't really show the
end of a file. But it appears to work with 1.6.


   Jeremy C. Reed