Subject: Re: machine-independent cycle counter based microtime()
To: Greywolf <firstname.lastname@example.org>
From: Jonathan Stone <jonathan@DSG.Stanford.EDU>
Date: 01/21/2003 12:15:42
>...why not just call it cycletime()? That should get us into the next
>century or so.
We have all these nice POSIX interfaces, with nanosecond resolution,
betwween userspace and the kernel. Once these nanosecond-resolution
values get into the kernel, we throw away three orders of magnitude of
resolution by keeping everything internally in microseconds.
Cleaning up the in-kernel interfaces is a Good Thing, but we should
provide nanosecond resolution internally (in the kernel) from the
In a separate but related issue, microsecond-resolution NTP code is
... getting pretty lame, by today's standards. (Cycletime(), you say?
On which CPU, given an SMP system with multiple distinct CPU-clock