Subject: Re: machine-independent cycle counter based microtime()
To: Jonathan Stone <jonathan@DSG.Stanford.EDU>
From: Greywolf <email@example.com>
Date: 01/21/2003 12:05:34
On Tue, 21 Jan 2003, Jonathan Stone wrote:
[JS: Also, if we're going down this route, can we please, *PLEASE*
[JS: construct _nano_time counters, not microtime? It doesn't require any
[JS: more bits, and microtime() on multi-GHz CPus looks a bit silly.
...why not just call it cycletime()? That should get us into the next
century or so.
Either that or you can look at the "micro" in microtime as having its
original (non-computer-based) meaning, i.e. "(very) small"...
NetBSD: it'll be there when you're ready for it.