Subject: Re: HPT366 lockups
To: None <>
From: None <>
List: tech-kern
Date: 04/09/2002 08:47:56
On Tuesday, April 9, 2002, at 07:32 AM, Sean Davis wrote:

> Hi, for as long as I can remember, I've been having this problem. The
> problem is when I do a bunch of disk I/O on my second ATA66 drive, my
> machine totally locks up. It's repeatable, but not always the exact same
> circumstances will cause it. Sometimes it happens when I had been doing
> things with the second ATA66 drive (from here on just referred to as 
> wd1)
> and do something that causes a lot of activity on the first ATA66 drive
> (from here on referred to as wd0), sometimes when moving files around 
> on wd1
> without touching wd0, but basically the best way I can think of to 
> describe
> what leads to it happening is "a bunch of disk I/O."
> My configuration is:
> Abit BE6-II motherboard with latest bios update (HPT366 BIOS v1.25)
> Intel Pentium-III Celeron at 533mhz
> First IDE controller:
> Master: ASUS CD-ROM
> Slave: Pioneer DVD-ROM
> Second IDE controller:
> First ATA66 controller:
> Master: IBM Deskstar ATA66 (19674MB)
> Second ATA66 controller:
> Master: IBM Deskstar ATA100 (19470MB) (running at ATA66)
> I have been looking through the mailing list archives, and I'm not the 
> only
> one who has had this problem, but I don't see any solutions or 
> workarounds
> (other than switch the disks to using PIO, which isn't an option, if I
> wanted PIO I wouldn't have bought ATA66 disks)
> I think the most important thing to note here is that this never once
> happened in Windows 98, and the last time I tried Win98 I had the same 
> drive
> on the first ata66 controller, and a maxtor ATA66 on the second. I am 
> 100%
> positive it isn't happening because wd1 is bad, because I have had this
> happen with something like four or five different ATA66 drives up to 
> this
> point.
> So ISTM there is some quirk/bug/whatever in the HPT366 on the Abit 
> BE6/BP6
> motherboards relating to using both ATA66 channels that windows handles
> correctly, and NetBSD doesn't? Maybe correctly isn't the word, but 
> handles
> without the system locking up in any case.
> Does anyone know if this is fixable in NetBSD at all?
> I am probably going to be buying a Promise PCI ATA100 TX2 card as soon 
> as I
> can afford it, but I would really like the existing hardware 
> configuration
> to work.
> FWIW, this happened in FreeBSD as well. I didn't have two ata66 drives 
> in
> here during the short time this box ran Linux, so I never found out if 
> Linux
> would have the same problem, though if what I've found sifting through 
> the
> web for information, it seems that Linux does.
> Any help is greatly appreciated.

	I ran into this using FreeBSD and RedHat GNU/Linux on an Abit BP6 
with two 500 mhz Celerons.  Any time I did a make world, or tried to 
build Java, I would get a lockup.  RedHat behaved similarly when disk 
i/o was high.  The flaky hardware issues with this mobo led me to buy my 
first Macintosh.  It's a G4 and runs just fine.
	I didn't run into any problems when I set the drives to use PIO, 
but it was noticeably slower.  Another note, myself and 3 hours on the 
phone with Microsoft Tech Support were not able to install Windows 98SE 
on this mobo.  This may be an Abit thing.  I have seen recommendations 
to upgrade to a newer BIOS version in threads on GNU/Linux mailing 
lists.  You may want to try that.