Subject: i386 installation problems
To: None <>
From: Reinoud Zandijk <>
List: tech-kern
Date: 02/24/2002 22:30:27
Hiya all,

today i helped a friend installing NetBSD-current (3 days old?) on a pretty
new Atlon board... the kernel worked fine (well ... in the end) _but_ i had
to note the following :

First, if the bios had a `PnP OS' option on it just completely messed up
NetBSD as devices can't get mapped etc... in this case leaving a machine
without any network ... the network card couldn't map its IO space, and
then its memory space etc... switching that `PnP OS' flag off made all work

Can't this be detected and a warning given ? or a big warning given in the
installation docs? this is pretty hard to find since it is one of those
small configuration options in BIOS'ses, nowmally by default on even ....  
but it has big consequences.

Secondly our XF 3 and XF 4.2 both recognize the NVidea Geforce 2 MX card
and even gets a display up but there is a serious problem that makes it
competely useless ... for some reason Xterms work fine but if I open a menu
in TWM it shows the outline of the menu but only paints the contents of the
menu when i move my mouse over it and it gets highlighted. The same for
running Opera ... Some parts are shown fine but others just keep blank!  
making it useless too. I really dont have a clue as to what this could be
esp. since it occures in XF3 and XF4.2 .... even running xrefresh gives
only the outlines and no contents. I tried it with a kernel without shared
memory and a kernel with shared memory with no effect.

A bit frustrated it got when we tried to get a SB Audigy working... its not
supported in NetBSD but it is in linux :( (AFAIK!) ... but well thats

anyway ... me might have lost the fellow to M$ win 2000 again :( or linux
... I tried ;)