Subject: Re: linux compat kernel version (was: CVS commit: syssrc/sys/compat/linux)
To: Christos Zoulas <>
From: Eric Haszlakiewicz <>
List: tech-kern
Date: 02/17/2002 13:06:28
On Sat, Feb 16, 2002 at 03:57:58PM -0500, Christos Zoulas wrote:
> On Feb 16, 11:44am, (Eric Haszlakiewicz) wrote:
> -- Subject: Re: linux compat kernel version (was: CVS commit: syssrc/sys/comp
> | On Sat, Feb 16, 2002 at 12:06:11AM -0500, Christos Zoulas wrote:
> | > Is that all there is missing? Try running jdk-1.4.0... It dies long
> | > before it gets any signals....
> | 	really?  When I tried it it actually managed to get going long enough
> | to spit out some messages, at least for some simple test programs, and stuff
> | like the included utlities.  It just hangs when exiting, after trying to do
> | some signal stuff.  The only thing I had to do was make sure my datasize limit
> | was high enough.
> On x86? When? Before I fixed some of the 64 bit calls I could not even unpack
> it... Now it dies de-referencing NULL, after loading
	Yes x86.  Current running with 1.5ZA built on Jan 29th.  I extracted the
java sdk on December 1st, obviously with an earlier kernel.  I just tried it
again and extracting it worked fine.  hmm... the file I actually downloaded
is called j2sdk-1_4_0-beta3-linux-i386.bin.  I guess 1.4 is actually released
now so there'll be a different binary.  I'll try it out.
	64-bit calls?  huh?  Do you mean like stat64?