Subject: softdep panic on 1.5.2/alpha
To: None <>
From: Rumi Szabolcs <>
List: tech-kern
Date: 01/26/2002 13:07:01

Maybe this is the wrong place to post that - if this is
the case, please forgive me...

So I recently installed 1.5.2-release onto my DEC Multia.
After installing, I enabled softdeps, and tried to
extract pkgsrc...

...and then i found myself in the kernel debugger:


panic: softdep_update_inodeblock: update failed
Stopped in tar at cpu_Debugger+0x4:	ret	zero, (ra)
db> trace
cpu_Debugger() at cpu_Debugger+0x4
panic() at panic+0xfc
softdep_update_inodeblock() at softdep_update_inodeblock+0x1e8
ffs_update() at ffs_update+0x294
ffs_full_fsync() at ffs_full_fsync+0x318
ffs_fsync() at ffs_fsync+0x60
vinvalbuf() at vinvalbuf+0x7c
vclean() at vclean+0x110
vgonel() at vgonel+0x64
getnewvnode() at getnewvnode+0x240
ffs_vget() at ffs_vget+0x84
ffs_valloc() at ffs_valloc+0xf0
ufs_makeinode() at ufs_makeinode+0xbc
ufs_create() at ufs_create+0x40
vn_open() at vn_open+0x14c
sys_open() at sys_open+0xf0
syscall() at syscall+0x1dc
XentSys() at XentSys+0x50
--- syscall (5, netbsd.sys_open) ---
--- user mode ---


then I checked out a 1-5-branch kernel from cvs, and tried
to reproduce that: yes, it is reproducible on 1.5.3-ALPHA.

here is a dmesg of the machine:


NetBSD 1.5.3_ALPHA (ALPHA-$Revision: $) #0: Sat Jan 26 09:12:09=
 CET 2002
(PCI ISA), 167MHz
8192 byte page size, 1 processor.
total memory =3D 65536 KB
(2368 KB reserved for PROM, 63168 KB used by NetBSD)
avail memory =3D 55488 KB
using 407 buffers containing 3256 KB of memory
mainbus0 (root)
cpu0 at mainbus0: ID 0 (primary), LCA-2 (21066 pass 2)
cpu0: VAX FP support, IEEE FP support, Primary Eligible
lca0 at mainbus0
pci0 at lca0 bus 0
pci0: i/o space, memory space enabled, rd/line, rd/mult, wr/inv ok
siop0 at pci0 dev 6 function 0: Symbios Logic 53c810 (fast scsi)
siop0: interrupting at isa irq 11
scsibus0 at siop0: 8 targets, 8 luns per target
sio0 at pci0 dev 7 function 0: Intel 82378ZB System I/O (SIO) (rev. 0x03)
de0 at pci0 dev 8 function 0
de0: interrupting at isa irq 14
de0: DEC 21040 [10Mb/s] pass 2.3
de0: address 08:00:2b:e4:de:bd
unknown vendor 0x0001 product 0x0000 (miscellaneous prehistoric, revision=
 0x01) at pci0 dev 9 function 0 not configured
tga0 at pci0 dev 11 function 0: DC21030 step B, board type T8-02
tga0: 1152 x 900, 8bpp, Bt485 RAMDAC
tga0: interrupting at isa irq 10
wsdisplay0 at tga0: console (std, vt100 emulation)
isa0 at sio0
com0 at isa0 port 0x3f8-0x3ff irq 4: ns16550a, working fifo
com1 at isa0 port 0x2f8-0x2ff irq 3: ns16550a, working fifo
pckbc0 at isa0 port 0x60-0x64
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pmsprobe: reset error 5
lpt0 at isa0 port 0x3bc-0x3bf irq 7
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
isabeep0 at pcppi0
fdc0 at isa0 port 0x3f0-0x3f7 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB, 80 cyl, 2 head, 18 sec
mcclock0 at isa0 port 0x70-0x71: mc146818 or compatible
pcic0 at isa0 port 0x3e0-0x3e1 iomem 0xd0000-0xdffff
pcic0: controller 0 (Intel 82365SL Revision 1) has sockets A and B
pcic0: controller 1 (Intel 82365SL Revision 1) has no sockets
pcmcia0 at pcic0 controller 0 socket 0
pcmcia1 at pcic0 controller 0 socket 1
stray isa irq 3
stray isa irq 4
scsibus0: waiting 2 seconds for devices to settle...
siop0: alloc newcdb at PHY addr 0x40930000
siop0: target 6 using tagged queuing
sd0 at scsibus0 target 6 lun 0: <IBM, DORS-32160, S82C> SCSI2 0/direct=
siop0: target 6 now synchronous at 10.0Mhz, offset 8
sd0: 2063 MB, 6703 cyl, 5 head, 126 sec, 512 bytes/sect x 4226725 sectors
pcic0: controller 0 detecting irqs with mask 0xdeb8:..5..15
pcic0: using irq 5 for socket events
ep0 at pcmcia0 function 0 port 0x400-0x40f: 3Com 3c589 10Mbps Ethernet
ep0: address 00:60:97:cc:08:b9, 8KB byte-wide FIFO, 5:3 Rx:Tx split
ep0: 10baseT, 10base5, 10base2 (default 10baseT)
root on sd0a dumps on sd0b
mountroot: trying nfs...
mountroot: trying msdos...
mountroot: trying cd9660...
mountroot: trying ffs...
readclock: 2/1/26/9/51/14=3D>1012038674 (1012038296)
root file system type: ffs
init: copying out path `/sbin/init' 11
de0: autosense failed: cable problem?
pcmcia0: card irq 15
stray isa irq 15


btw. as it can be seen above, it shows the infamous
stray irq problem as well. 

Best regards,

Szabolcs Rumi