Subject: Re: Console polling programming interface change (proposal)
To: None <>
From: Christos Zoulas <>
List: tech-kern
Date: 07/19/2001 20:52:00
In article <>,
Bill Studenmund <> wrote:
>I gather right now it's 'void (*cnpollc)(dev_t dev, int on)' ? Another
>option is:
>void (*cnpollc)(dev_t dev, int on, int *cookie)
>Then the caller doesn't have to do anything special about passing the
>cookie in or out.

I would use void *cookie, since cookies are usually magic and nobody
knows what they contain before they open them... Unless you always
know what it is going to be... In that case you should name it