Subject: Re: Softdep with ffs, how broken is it?
To: None <>
From: Petri Koistinen <>
List: tech-kern
Date: 07/01/2001 03:21:12
On Sat, 30 Jun 2001 wrote:

> > I am one of those unlucky people that tried to use soft-depencies with ffs
> > in order to make it work faster and ended up crashing their machine under
> > heavy load.
> how do you define "heavy load" and what is the netbsd version.

Heavy load could be for example:
(cd /usr/src/ ; cvs update) & (cd /usr/pkgsrc/ ; cvs update)
I am running on 1.5W (build 30th June) now.
> on my home machine i sometimes uncompressed 2 tar.gz's with lots of
> small files etc..  worked perfect.

I must admit that -current seems to be stable now, maybe something has
changed and I can't cause anymore kernel panic.

Before softdep_update_inodeblock() was causing panic. After crash I made
kernel with DIAGNOSTIC option turned on and didn't manage to get kernel
panic. Still once under heavy load I got strange message:

Data modified on freelist: word 10 of object 0x307b00 size 84 previous
type UVM amap (0x2f1958 != 0xdeadbeef)

Data modified on freelist: word 6 of object 0x2f1940 size 28 previous type
diradd (0x307600 != 0xdeadbeef)

(There might be some spelling errors as I quickly copied that on paper
from screen.)

Crashing was quite hard already before, above heavy load wasn't always
panicing system. I managed to get kernel panic with "umount -f /usr" and
that problem is now gone too. I know that isn't smart thing to do, but
shouldn't cause kernel panic, but well it's gone, system only freezes
which is, I think, quite normal after such command. So maybe I don't write
that PR anymore, there are already pleanty of unresolved ones about