These are opflags, and should probably be named along the form DEV_WAIT or DEV_OP_WAIT. They shold not be PROP_ flags!!! O.K. I'll change the flag to `int wait' which is true/false. could this be `nowait' ? like much of the rest of the kernel. if it is nowait, you can do: (nowait & M_NOWAIT) .mrg.