Subject: Re: panic: softdep_deallocate_dependencies: dangling deps
To: None <>
From: Mike Cheponis <mac@Wireless.Com>
List: tech-kern
Date: 02/27/2001 18:47:48
On Mon, 26 Feb 2001, Manuel Bouyer wrote:

> Hum I know there are some issues with softdeps in 1.5. Maybe fixed in
> 1.5.1_ALPHA

> Could you check it's reproductible on your machine, and then try a newer
> kernel ?

I tried again with no processes:

$ dd if=4GB of=4g4

Worked great!

Then I started top (reniced to -20) the ntop (also reniced to -20) and
setiathome (reniced to +20).

$ dd if=4GB of=4g5

Then the box went into the dubugger:

NMI...  going to debugger

Stopped in dd@microtime: pushl %edi

At that point, I just type "g" and the "dd" finished and the box has been
up ever since; I haven't tried any more "dd" big file copies.

(I don't know what would have caused the NMI - but I do use ECC memory?)

Is this likely s/w?  Should I try anything else?  (I haven't upgraded yet
to the 1.5.1_ALPHA kernel, for instance.)

Thanks again -Mike

> On Sun, Feb 25, 2001 at 11:09:36PM -0800, Mike Cheponis wrote:
> > Help! I'm running 1.5 on K6-2/400 256MB 45G IDE disk w/softdeps on.