Subject: Re: More Device Properties
To: None <firstname.lastname@example.org, email@example.com>
From: None <firstname.lastname@example.org>
Date: 02/20/2001 19:54:49
> These are logically two different sets of flags. They should be
> Well, they are being passed in in the same `flags' field in
> dev_setprop() and dev_getprop() so it would be better if they
> don't conflict with one another.
I believe the point is, different sets of flags should _not_ be
#defined in the same set, _or_ passed together, _or_ stored together
in e.g. structures.
Why would it ever make sense to reserve a bit for PROP_WAIT in a
property structure, for instance?
PROP_WAIT does not make sense on a property structure. So
you want to pass 3-4 different `flag' parameters to these calls?
Actually, come to think about it, the only flag that would
ever be actually attached to a property would be PROP_STRING,
and I hope to find some way of marking a property as a string
without requiring an extra flag field. So, for the most part,
the flags change the behavior of specific functions.