Subject: Re: COMPAT_LINUX and RT signals
To: Emmanuel Dreyfus <>
From: Jaromír Dolecek <>
List: tech-kern
Date: 02/08/2001 13:10:34
Emmanuel Dreyfus wrote:
> Well... That's a problem: if we use Linux's glibc-2, it appear to only
> use rt signals. And Netscape seems to needs glibc-2. [that one should
> have gone to port-powerpc]

Last time I looked, glibc used RT signals if uname(2) returned
kernel version >= 2.1.70. Our Linux emulation returns 2.0.38,
so it should make linuxthreads use common signals.

Jaromir Dolecek <>
@@@@  Wanna a real operating system ? Go and get NetBSD, dammit!  @@@@