Subject: Boot failure with Adaptec 2940UW present in NetBSD/macppc system
To: None <>
From: Michael Wolfson <>
List: tech-kern
Date: 10/12/2000 22:08:49

I just tried booting a 1.5_ALPHA2 kernel on my PowerMac 7500 with an
Adaptec 2940UW PCI card, (firmware version 4.1).  I can load almost any
kernel from floppy or a SCSI drive on another bus (MESH "internal" or NCR
"external").  Once it gets to the point of probing the SCSI busses for
devices, it always fails in pretty much the same way:

ahc0 at pci0 dev 15 function 0
ahc0: interrupting at irq 25
ahc0: aic7880 Wide Channel A, SCSI ID=7, 16/255 SCBs
scsibus0 at ahc0 channel 0: 16 targets, 8 luns per target
Waiting 2 seconds for scsi devices to settle
ahc0: ahc_intr = referenced scb not valid during SELTO scb(9, 255)
[repeats a lot]
probe(ahc0:0:0): SCB 1d - timed out while idle, SEQADDR == 0x5
probe(ahc0:0:0): SCB 1d: Immediate reset.  Flags = 0x4040
probe(ahc0:0:0): no longer in timeout, state = 0
panic: Waiting List inconsistency.  SCB index == 255, yet numscbs == 30.
stopped at cpu_Debugger+0x10:    lwz r0, r1, 0x14,
db> trace
at wskbd_cnbell+190
at wskbd_cnbell+1348
at wskbd_input+68
at kbd_intr+bc
at kbd_adbcomplete+c0
at kbd_adbcomplete+5c
at adb_soft_intr+d0
at softclock+208
at hardclock+23c
at decr_intr+118
at extint+call+180
at cpu_switch+30
at mi_switch+1a0
at ltsleep+294
at scsipi_execute_xs+f8
at scsi_scsipi_cmd+190
at scsipi_command+bc
at scsipi_inquire+7c
at scsi_probedev+d0
at scsi_probe_bus+108
at scsibus_config_interrupts+64
at config_interrupts+16c
at configure+78
at main+41c
at __start+90

The drive is terminated, and works fine with MacOS.  I also tried booting
with just the Adaptec card (no drive) and it exhibited the same problem.

The kernels I tried are:

The firmware driver for the Adaptec card is from:
One interesting note is that they have different drivers for "AV PowerMacs"
and everything else (where the "AV PowerMacs" are the 7200-9600").

I don't have a working macppc system (so I can't compile new kernels), but
I can burn test kernels to a CD-R.  Any suggestions, other than unplugging
the Adaptec PCI card?

  -- MW