Subject: Re: power hook and spl level
To: John Hawkinson <jhawk@MIT.EDU>
From: Lennart Augustsson <>
List: tech-kern
Date: 09/05/2000 23:02:59
John Hawkinson wrote:

> | >         do you guys think this is necessary for netbsd too?
> | >         or it is drivers that need to be corrected?
> |
> | Our power hooks run at splhigh() (in current), so it should not
> | be needed.
> Certainly the wavelan driver still needs a power hook.

Yes, I'm sure it does.  But as I understood the question it was if the
powerhook needed to be wrapped in splimp().

    -- Lennart