Subject: Re: ppsratecheck(9)
To: None <enami@but-b.or.jp>
From: None <itojun@iijlab.net>
List: tech-kern
Date: 07/08/2000 00:09:12
>> + if ((lasttime->tv_sec == 0 && lasttime->tv_usec == 0) ||
>> + delta.tv_sec > 0) {
>> + *lasttime = mono_time;
>> + *curpps = 0;
>> + rv = 1;
>> + } else if (*curpps < maxpps)
>> + rv = 1;
>> + else
>> + rv = 0;
>> + /* be careful about wrap-around */
>> + if (*curpps + 1 > *curpps)
>> + *curpps = *curpps + 1;
>If it reached to the limit, we don't need to increment it, do we?
I do intend to increment it, someone can use the counter variable
for statistics purposes.
>> you may have different idea about function names or argument types,
>> i'm not good at naming things:-)
>psratecheck (per second rate check)? I'll strongly agree with you
>that at least the acronym pps isn't generic enough.
while i agree pps is not a generic name, "ps" looks like "process"...
:-P
itojun