Subject: Coda in -current ...
To: None <>
From: Phil Nelson <>
List: tech-kern
Date: 06/09/2000 10:42:21
Hi.  As 1.5 approached, I decided I needed to verify that the
coda kernel module was still working in -current. 

So I built:
NetBSD puffin 1.4Z NetBSD 1.4Z (PUFFIN) #1: Wed May 31 15:07:06 PDT 2000
... i386.

And when I got coda-current compiled and installed, I ran a coda client.
The result was some vnode problems:

   a) quickly I got a panic with
        vref used where vget required

	backtrace included
	    vref(...) at vref+0x19
	    namei(...) at namei+0x157
	    sys___stat13(...) at sys___stat

   b) later I got a panic with
        vrele: ref cnt

I'm assuming that they are the same error in that some place in coda,
the code didn't do a vget where it should have.

I believe I saw some mention of changes to the vnode system between
1.4 and now, but I wasn't watching closely enough (and I don't know
the coda module enough) to know how those changes should be delt
with in coda.

Any pointers or help would be appreciated.

Phil Nelson
e-mail:  (Work: