Subject: Re: Absolute location pointing device
To: TAKEMURA, Shin <>
From: Chris G. Demetriou <>
List: tech-kern
Date: 12/28/1999 12:28:42
"TAKEMURA, Shin" <> writes:
> 1. Add an argument to wsmouse_input(). The new argument is flag, which 
>    indicate whether the cordinates are absulute or relative. If the
>    coordinates are absolute, the wsmouse_input produce an 
>    WSCONS_EVENT_MOUSE_ABSOLUTE_X event instead of ..._DELTA_X.
>    (WSCONS_EVENT_MOUSE_ABSOLUTE_X is alredy defined in wsconsio.h.)

This is probably reasonable.  (you might want to do it in a
source-backward-compatible way, but there shouldn't be many places
that call wsmouse_input().)

> 2. Define new mouse type WSMOUSE_TYPE_VRPIU or WSMOUSE_TYPE_TPANEL
>    (The former means VR41xx built-in touch panel controller, and the
>     latter means a general touch panel. Which is better?)

The rationale for providing different 'types' for displays and mice
was twofold:

* to provide generic identification of the specific family of device,
e.g. PS/2 mice, or DEC SFB controller, or...

* to provide identification of boards with specific
requirements/features, so that user-land code could know that it's
doing something special.

I would suggest either: a "touch-screen generic" name, if you see no
reason to distinguish between this and other touch screens (and you
expect them to support the same set of controls, etc); or a specific
name for this controller type, if you think that there will be
specific features that are not particularly generic that you'll be
providing ioctls, etc., for.

I wouldn't really suggest a "tablet"-like name, because this isn't a
tablet.  For instance, what's the actual difference between the
facilities available from a PS/2 mouse, a DEC VSxxx serial mouse, a
Logitech busmouse, and an 'mms'?  (there may be some, but i believe
them to all be rather generic classes of feature, e.g. settable input
sampling rate, different number of buttons.)  Part of the TYPE naming
is just for identification, and a tablet doesn't look much like a
touch screen to me.

It's all very ad hoc...

> 3. Introduce a new I/O controll command WSMOUSEIO_SPARAMS, with which we
>    can put sample coordinates retrieved with calibration. 
>    WSMOUSEIO_GPARAMS is also needed.

You need a better name than that; it definitely sounds like you want
something different than might be parameters for a generic mouse.  8-)

you probably want to mention coordinate calibration, somehow.  8-)

Chris Demetriou - -
Disclaimer: Not speaking for NetBSD, just expressing my own opinion.