Subject: Re: renaming /boot to /boot_
To: Simon Burge <firstname.lastname@example.org>
From: Robert Elz <kre@munnari.OZ.AU>
Date: 09/28/1999 20:25:11
Date: Tue, 28 Sep 1999 11:17:14 +1000
From: Simon Burge <email@example.com>
| heh; i had thought boot_pmax like we have fsck_xxx, mount_xxx, etc...
| and that's where it got upto before being moved to tech-kern.
| I'm happy with the boot_<arch> idea (as long as ``_'' is a valid
| character in a standard cd9660 filename). Comments from anyone else?
Could someone not consider boot/pmax boot/i386 (etc) ?
For systems whose first stage boot has block numbers built in, this makes
no difference at all to anything. For those that actually do a lookup of
"/boot" (or /boot_pmax or /boot/pmax or whatever is selected), using the
directory method should provide much better compatability and simplicity, the
first stage boot can just look for /boot first, if that turns out to be
a directory rather than a file, then append the arch and loop back and
repeat the lookup. Just an extra couple of lines to allow support of
both single arch boot (/boot) and multi-arch (/boot/*).
Whenever anyone is tempted to start building file names out of pieces
that indicate different things, they really ought look and see whether or
not using sub-directories would work - if it does it is a MUCH cleaner