Subject: Re: Changing the semantics of splsoftclock()
To: Bruce Evans <>
From: Peter Wemm <>
List: tech-kern
Date: 06/27/1999 13:26:42
Bruce Evans wrote:
> >>Why have splr semantics? That is, it raises to splsoftclock if current
> >>priority is lower, else doesn't fiddle with it.
> splsoftclock() has always had spllower() semantics, and its main users
> (kern_clock.c and kern_time.c) depend on this.
> FreeBSD has a precedent of not changing poor spl names because the change
> would be confusing: splnet() should be named splsoftnet() and splimp()
> should be named splnet() as in NetBSD.

I would like to correct this, it is a source of problems when dealing with
NetBSD code.  It would be a relatively harmless change for us since it's
failure mode is fairly benign.  Old code calling splnet() that gets missed
will still work, just it will block more than is strictly required.
splimp() callers will get found quickly since they'll be an undefined

However, it would make backporting drivers from -current to 3.x a bit of a

> Bruce

Peter Wemm -;;