Subject: Re: Changing the semantics of splsoftclock()
To: None <,>
From: Bruce Evans <>
List: tech-kern
Date: 06/26/1999 08:28:15
>>Why have splr semantics? That is, it raises to splsoftclock if current
>>priority is lower, else doesn't fiddle with it.

splsoftclock() has always had spllower() semantics, and its main users
(kern_clock.c and kern_time.c) depend on this.

FreeBSD has a precedent of not changing poor spl names because the change
would be confusing: splnet() should be named splsoftnet() and splimp()
should be named splnet() as in NetBSD.