Subject: Re: Changing the semantics of splsoftclock()
To: Bruce Evans <>
From: Matthew Jacob <>
List: tech-kern
Date: 06/25/1999 15:29:51
> >>Why have splr semantics? That is, it raises to splsoftclock if current
> >>priority is lower, else doesn't fiddle with it.
> splsoftclock() has always had spllower() semantics, and its main users
> (kern_clock.c and kern_time.c) depend on this.

Okay. Then Justin's suggestion of splcallout with splr semantics makes

> FreeBSD has a precedent of not changing poor spl names because the change
> would be confusing: splnet() should be named splsoftnet() and splimp()
> should be named splnet() as in NetBSD.

I'm not sure what this means. I guess the gist is "don't change