Subject: Re: VME ie card on sun3 (sun4 people also please read)
To: Alex Barclay <>
From: Rafal Boni <>
List: tech-kern
Date: 04/29/1999 23:03:43
In message <>, you write: 

-> I have recently tried to install a extra ie card into my Sun 3/470
-> (The card is a multibus into vme converter affair)
-> Anyway it failed miserably! :-(

-> The card seems to be failing to initialise the memory on the card,
-> not sure why but it then generates an interrupt. As soon as
-> interrupts are enabled I get unclaimed interrupt scrolling up off the
-> screen.

Hmm.  I had similar experience with a Intel EtherExpress/16 on my x86 PC
the other day (this is also based on i82586 chip).  If I mapped in 32K of
memory, the card worked A-OK.  If I configured the card for 16K of memory,
I got something quite similar to what you describe (a near-continuous
stream of spurious interrupts from the card).  Does you card only have 16K
of memory, by any chance?  I'd bet that this configuration hasn't been tested
real well (I've mostly used 32K and 64K memory windows for the ISA 82586 cards
I own, other than the EtherExpress experiment...)

I plan on looking at this soon, as I'm done with a big project at work this
week, so should have a few spare cycles in the near future.  I'm not sure it
is 100% related to your problem, but it sure sounds similar.

I'm sorta familar with the 82586 chip itself (and actually now own a paper 
databook and reference), as I've had my hands in the driver(s) for it at
various stages, so feel free to ask me questions, although I know nothing
about VME and very little about Sun3's.


Rafal Boni