Subject: Re: NetBSD-1.3.2 Y2K problem
To: None <>
From: None <>
List: tech-kern
Date: 10/08/1998 12:58:22
> Dear Mr. Havard,
>         I regenerated my kernel again and it still having error:-
> 1) I removed my compile directory
> 2) I ran "config YBNG in /sys/arch/i386/conf"
> 3) I checked /sys/arch/i386/compile/YBNG there is no pcppi.h
> 4) I created pcppi.h by "echo '#define NPCPPI
> 0'>/sys/arch/i386/compile/YBNG/pcppi.h"
> 5) I ran "make depend"
> 6) I ran "make netbsd"
> After I ran "make netbsd", there is an error came out:-
> cc1: warning being treated as errors
> .../sys/arch/i386/isa/clock.c    In function 'gettick'
> .../sys/arch/i386/isa/clock.c     307     implicit declaration of function
> 'read_eflags'
> .../sys/arch/i386/isa/clock.c     313     implicit declaration of function
> 'read_eflags'
> Error code 1
> Am I doing anything wrong or missing anything with applying clock.c 1.53?

Well, the only "wrong" thing you do is to try to implant new code
into an older set of kernel sources, and you appear to have
tripped over a few rough edges in doing so.  (In general, this
isn't "guaranteed" to work, so...)

It would seem that you could try to pull over a new version of
/sys/arch/i386/include/cpufunc.h -- read_eflags() is defined as
an inline function in my copy of that file.  Just remember to
stash your old copy where you can recover it if for some reason
this should fail to work.


- H=E5vard