Subject: FFS compatibility
To: None <>
From: Matthias Drochner <>
List: tech-kern
Date: 09/07/1998 21:53:34
When I tried to access an ULTRIX filesystem from
NetBSD-current/pmax I found that the support for the
old style BSD filesystems got broken between 1.3 and
This is due to a lot of checks for "old style" filesystems
which use "mnt->mnt_maxsymlinklen == 0". This should
be "<= 0"; at least for me the "maxsymlinklen" is -1 with
the old filesystems.
There is a lot of unused flag bits in struct ufsmount->um_flags,
so I propose to dedicate one of them to the "old filesystem"
property, and to clean up the whole mess.

best regards