Subject: Re: 32 bit dev_t
To: Chris G. Demetriou <>
From: Darren Reed <>
List: tech-kern
Date: 01/16/1998 11:10:16
In some mail I received from Chris G. Demetriou, sie wrote
> My suggestion here is "do it the way BSDI did'.
> Like I said, I'm just not particularly concerned about MAKEDEV/mknod
> compatibility.
> Having 'dv_unit()' and 'dv_subunit()' in the kernel would be a good
> idea. Also a good idea might be to rename 'minor()' in the kernel to
> 'dv_minor()', so that no devices will ever try to use the old
> semantics of minor numbers again w/o being inspected. we really need to do that ?

> There's only so much in the way of semantic freedom a given device
> should have in interpreting its device nodes.  'real' devices should
> use 'dv_unit()' to figure out which device unit is being accessed.
> dv_subunit() usage should be device dependent, but should be
> as consistent as possible within classes of devices.
> I'm not even so convinced that things like BPF, which BSDI allowed to slide
> by using the old minor() should be allowed to do so.

And what would you have had them do in this case instead of that ?