Subject: Re: bus.h style question
To: Chris G. Demetriou <>
From: Eduardo E. Horvath <>
List: tech-kern
Date: 08/23/1997 10:32:19
> >So, thinking about the names makes me want something like:
> >
> >	bus_space_read_region_*s
> >
> I was thinking about better names, too; even i hated  my ones
> Jason objected to.

> 	bus_space{read,write}_N ->   bus_space_{read,write}_int{8,16,32,64}

> 	bus_space_{read,write}_byte{1,2,4,8}

> Comments??

Seems to me that the `space_' is completeley gratuitus and can be removed
with no loss of information:


Or (maybe less intuitive) use:


for `bus native' (byte swapped) I/O and:


for `stream' I/O.

Eduardo Horvath
"Cliffs are for climbing.  That's why God invented grappling hooks."
					- Benton Frasier