Subject: Re: bus.h style question
To: Jason Thorpe <>
From: Chris G. Demetriou <>
List: tech-kern
Date: 08/21/1997 14:33:21
> bus_space_stream_{read,write}* matches bus_space_stream_read_multi_* and
> bus_space_stream_read_region_*  :-)
> (How about a contest - who can come up with the longest function name? :-)

So, thinking about the names makes me want something like:


i.e. bus_space_read_region_2s.

"read" vs. "write" tells you direction, "" vs. "multi" vs. "region"
tells you where to get the data from, and "2s" tells you the size and

of course, *2 is easily confused with *2s, etc., but i really don't
want to be faced with page-long function names.  8-)